Ticket #109 (closed defect: fixed)

Opened 9 years ago

Last modified 9 years ago

Could not find tracklog folder

Reported by: danielvelezbravo@… Owned by: ste
Priority: major Milestone: 1.2.5
Component: FsComp Version: 1.2.3
Keywords: Cc:

Description

I´ve downloaded version 1.2.3. I opened a competition database that was previously scored with 1.1.7 and it opens ok. Nevertheless, whe software can´t find the tracklog folders, even when I brownse for them.

My folder structure has spaces and it´s quite long, such as:

C:\Users\Daniel Velez\Documents\GPS_Files\Santa Cruz Flat Lands 2008\Day 5

Version 1.2.2. seems to handle this issue fine. I downgraded to 1.2.2. until 1.2.3. can re-load the long folder structure for tracklogs folders.

Change History

comment:1 Changed 9 years ago by ste

  • Owner changed from somebody to ste
  • Status changed from new to assigned
  • Version changed from 1.2.2 to 1.2.3

comment:2 Changed 9 years ago by ste

Investigating the matter.

Not said above but I suppose it would be happening when checking tracklogs. Normally the reason for a message like "Could not find tracklog folder 'Day 5'" would be that one has moved the fsdb file or the tracklog folder.

When the tracklog folder is a relativ path it is expected to be relativ to the folder where the fsdb file is.

If one do get such a message, simply click on the "Browse..." button and select the folder where the tracklogs are. Unless there is a bug here somewhere that shows up in special cases this should work.

Stein-Tore

comment:3 Changed 9 years ago by danielvelezbravo@…

I have downloaded newer 1.2.4 version and it gives a newer error. When I open up a previously 1.1.7 flight database, that can show tracks on the task map and that has been scored, and try to show the task map to load one of the flights, as soon as I hit anyones flight i would get an error that´s on my local language (spanish) even though FS is on english, and that basically says:

Can´t find a part of the file access route 'C:\Users\Daniel Velez\Documents\GPS_Files\FS\Day 1\140.kml'

Actually the current path woult be 'C:\Users\Daniel Velez\Documents\GPS_Files\Santa Cruz Flat Lands 2008\Day 1\140.kml'

It seems that even when the *.fsdb file is stored under a directory called Santa Cruz Flat Lands, that´s in the same directory level than the FS application, the software assumes that the relative path would be assuming a relationship to the FS.exe file instead of the FSDB file.

My folder structure is as follow:

c:\...\gps_files\FS - Here I have all the FS files, unzipped from the last zip. c:\...\gps_files\Santa Cruz Flat lands 2008 - Inside you would find the FSDB file, the task results, the templates, and subfolders called Dia 1, dia 2, dia 3, etc, that contains all the tracklogs for that day.

It works on 1.2.2. but somehow the relative path is not working anymore even when I try to brownse for it.

In order to replicate the error, you should try to put all the FS files on a different place than the user competition data, say put the program under Program Files, and the competition data, meaning the FSDB and the tracklogs under some other folder, deep into your "my documents" folder, and try to plot one of the tracks into the task map.

comment:4 Changed 9 years ago by ste

Anyone else having same (or similar) problem?

I am unable to reproduce this on my computers, have now got the data from Daniel and still no "success".

Of note: version 1.2.4 was compiled with debug information and therefor may in some cases show errormessages that where not intended to bother the user with. This has no effect on the workings of the program.

Will get to the bottom of this by noon.

Stein-Tore

comment:5 Changed 9 years ago by ste

  • Status changed from assigned to closed
  • Resolution set to fixed
  • Milestone set to 1.2.4

A bug that snuck into FS in v 1.2.3 and 1.2.4.

FS 1.2.5 should be ok.

It seems to be related to different behaviour of certain methods in .NET in Windows Vista compared to earlier versions. Anyhow, have made workaround (more robust code) which should (hopefully) work regardless. (waiting confirmation from Daniel that it works).

Stein-Tore

comment:6 Changed 9 years ago by ste

  • Milestone changed from 1.2.4 to 1.2.5
Note: See TracTickets for help on using tickets.