Opened 11 years ago

Closed 11 years ago

Last modified 7 years ago

#139 closed enhancement (worksforme)

Feature Request: Combine elapsed time and race startgate in task.

Reported by: rafalopez Owned by: Stein Tore Erdal
Priority: minor Milestone:
Component: FsComp Version: 1.2.8
Keywords: race startgates elapsed time Cc:

Description

Try to classify a test: TIME ENLAPSED beginning with air and DEAD LINE. But it is not possible to conduct such tests with the FS. Not allowed to post a SS. Example: Take off 13:00 to 15:00 pm SS 001 Waypoint open 45 individual time with start entering, dead line 60. You can not set these options in FS however RACE if he supports. Excuse my bad English

Change History (17)

comment:1 Changed 11 years ago by Øyvind Ellefsen

Owner: changed from somebody to Øyvind Ellefsen
Status: newassigned

Just set the closing time of the SS cylinder to your deadline?

But if I i understand correctly you want to close the SS before the take off closes? This is not normal, as you want all your pilots in the air in good time to take the start gate...

  • Oyvind

comment:2 Changed 11 years ago by rafa lopez

Excuse me, it is difficult to explain using a web translator The SS NOT CLOSE, but the pilots departing after the dead line will have the time to start this dead line.

THE TASK: Type: Individual time, enlapsed time with Air start. window: 13:00 pm to 15:00 pm Air start open SS 13:00, close 15:45 dead line: 13:45 After 13:45 the pilots will have the same schedule Incio of proof (13:45 pm)

Tell me please you. if you understand my explanation

comment:3 in reply to:  2 ; Changed 11 years ago by Øyvind Ellefsen

OK - IF you want ELAPSED TIME, from 13:00 until 13:45 you must manually change the start time for all the pilots that started after 13:45. (I have never heard anyone using this type of task before)

The normal way to handle this is to set a RACE TASK, and have the last startgate at 13:45

comment:4 Changed 11 years ago by rafalopez

I have several tasks of this kind in the last 3 years .- one of them on 12/10/2008 Inetnete manually change the time of onset, but lost points for LD

I have also classified time with several tests enlapsed multiple SS, every 10 minutes .-

comment:5 Changed 11 years ago by Øyvind Ellefsen

Resolution: wontfix
Status: assignedclosed

Yes, you will loose leading Points when setting times manually, this is because leading points are calculated from the GPS tracklog, when you change the start time of the pilot the time in the tracklog becomes irrelevant. (These are the last pilots in the task and should not have much leading points anyway)

If I understand correctly, you want to combine elapsed time and race in the same task. This is not supported in FS today. You can achieve almost the same result by having a race with many startgates and short intervals as you have discovered.

I see that the combination of race task and elapsed time task is possible in RACE, as RACE does not check the tracklogs, and will not invalidate the tracklog for a pilot that start after the SS is closed.

I'm not sure if it's worth it to implement this task type in FS. Why not just run a race task. If the conditions are that bad pilots cannot stay up they should just start without thinking about the clock anyway.

comment:6 Changed 11 years ago by rafalopez

Hello, excuse my English. There are 2 kinds of tasks that can not reproduce. First type of task: Enlapsed time with dead time: It is used to prevent pilots who take advantage of others marking the path with candles much faster. Off after 1 hour and can fly too fast using the pilots in the air (you will have seen this situation in some PWC). If you use a Dead Line pilots are reduced this situation because if you take off 1 hour after take-off window open, as his time run from the Dead Line. This kind of evidence we have used several times in Argentina does not possess off to allow off more than 7 pilots at the same time. Using this method we have reduced the impact this form of flight. Dead Line SS is not close.

Second type of test: Enlapsed time using various SS. It is used to reduce the possibility that a pilot type 1, 2 ox minutes behind another pilot in which I start to see the condition in the air, as they will have no advantage of time because the same time that the pilot involved before.

Informed the pilots who do not perform such tasks .- ;-)

Thank you.

comment:7 Changed 11 years ago by Øyvind Ellefsen

I understand what you are thinking about.

This "problem" is solved by using the Race task type, with multiple startgates, and leading points. Then the pilots who chose to wait behind will loose many points, and can never win the task coming from behind.

There is no such thing as Elapsed time with various SS, this is a Race task.

comment:8 Changed 11 years ago by rafalopez

:-) if I was, however pilots who decide to work ideas are rare. Then I have to classify, with big headaches.

Ask us not to do more tasks of this type.

A query: ud. have known that the GAP awards points if the task is RACE TO GOAL or ENLAPSED TIME? I looked great differences just by changing the type of task. Pareceri those RAACE TO GOAL scores favoring Distance and ENLAPSED TIME favors time, I'm not sure that does this. Inicare a discussion forum on this situation

comment:9 in reply to:  3 Changed 11 years ago by anonymous

Resolution: wontfix
Status: closedreopened

We used this type of task in a World Cup in 2007 in Tucumán, and we used it again in the same place last week in World Cup Series, because of somehow similar conditions.

The reason why sometimes you make an elapsed time with a time deadline is because of the following:

  • conditions are not good to safely stay in the air in the ridge area for a race or for diff. start gates; this can be because of moderate winds parallel to the ridge that make take off tricky (turbulent) or because of very poor soaring conditions
  • the deadline is there so that pilots are encouraged to take off early and somehow avoid the usual speculation that come with elapsed time tasks
  • you do not want to close the take off early so as not to encourage pilots to take off in conditions that may be difficult for them, but also you do not want pilots flying the task with 2 hours of difference and individual clocks ...
  • you try to encourage pilots to go into the flats and avoid staying in the turbulent mountains

So, it is useful, and in RACE we solve it by manually correcting SS of pilots starting after deadline

Another issue, terminology ...

You say start gates are only race to goal, and elapsed time is only individual times. However, in many places we understand that tasks with many start gates are elapsed time tasks, and that race to goal are only the tasks with only one start time. CompeGPS & RACE work this way, if you want to put multiple start times, you have to choose elapsed time as the type of task. Googling you find both ways of expressing, but I would say that many treat multiple start gates as elapsed times tasks (british among them)

Replying to oyvellef:

OK - IF you want ELAPSED TIME, from 13:00 until 13:45 you must manually change the start time for all the pilots that started after 13:45. (I have never heard anyone using this type of task before)

The normal way to handle this is to set a RACE TASK, and have the last startgate at 13:45

comment:10 Changed 11 years ago by Øyvind Ellefsen

Keywords: race startgates elapsed time added
Milestone: 1.2.91.3
Owner: changed from Øyvind Ellefsen to Stein Tore Erdal
Priority: majorminor
Status: reopenednew
Summary: Air Start with ENLAPSED TIMEFeature Request: Combine elapsed time and race startgate in task.
Type: defectenhancement

Changed to feature request and assigned.

I see the use in the situation you describe, you can still set things manually in FS so it's solvable.

We have had some discussions regarding the terminology used in FS, and agreed on a common set of terms at the latest CIVL meeting. The terms used are described in the Wiki here; http://fs.fai.org/cgi-bin/trac.fcgi/wiki/DefinitionList

We are aware that RACE and other programs have used various terms, but we feel it was not a good idea to drag those errors and confusing terms into the future with FS. (Pilots are not happy about this sometimes, but the old ways are not always best... )

There is some work to sync this up with Section 7, I've started on this, expect to have it proposed for the next CIVL meeting in February.

Could I ask you to write an paragraph or two on the Wiki, describing the rationale behind this task type that you just explained? http://fs.fai.org/cgi-bin/trac.fcgi/wiki/FS%20Guide#Tasksandtasktypes

May I also ask you to use a name so we know who said what in the discussion here :-)

comment:11 Changed 11 years ago by rafalopez

Hello. excuse my English so bad. Eduardo is the one who post the above, reopening the ticket. The situation is solvable manually, but lost the points lead. You can assign points for Leadership manually, but it is cumbersome and can induce errors in the classification. The points of leadership can possibly change the classification

comment:12 in reply to:  10 Changed 11 years ago by Eduardo

Sorry for my distraction in posting as Anonymous !!!

I added the type of task, with a brief description in Wiki.

As you see, many of us are confused about terminology !!!

Finally I would like to say that "Elapsed Time with Start Deadline" tasks can also be seen as "Race to Goal" tasks with Jump the Gun enabled but Factor = -1

Don´t know if it is possible to set negative JG factors in FS If possible, then no enhancement would be needed !!!!!

Replying to oyvellef:

Changed to feature request and assigned.

I see the use in the situation you describe, you can still set things manually in FS so it's solvable.

We have had some discussions regarding the terminology used in FS, and agreed on a common set of terms at the latest CIVL meeting. The terms used are described in the Wiki here; http://fs.fai.org/cgi-bin/trac.fcgi/wiki/DefinitionList

We are aware that RACE and other programs have used various terms, but we feel it was not a good idea to drag those errors and confusing terms into the future with FS. (Pilots are not happy about this sometimes, but the old ways are not always best... )

There is some work to sync this up with Section 7, I've started on this, expect to have it proposed for the next CIVL meeting in February.

Could I ask you to write an paragraph or two on the Wiki, describing the rationale behind this task type that you just explained? http://fs.fai.org/cgi-bin/trac.fcgi/wiki/FS%20Guide#Tasksandtasktypes

May I also ask you to use a name so we know who said what in the discussion here :-)

comment:13 Changed 11 years ago by Stein Tore Erdal

Status: newassigned

Example:

Race to goal with one start gate.

The taskboard:

2009-05-10

Window open:           12:00
Window close:          14:00
Start gate:            13:00
End of task:           18:00

Jump the gun factor:   1
(Go whenever you want in the window open periode 
but your clock starts ticking no later than 13:00)



In FS:

TP1       open 12:00, close 18:00
TP2 SS    open 12:00, close 18:00
TP3 ....

Startgate(s): 
2009-05-10 13:00


Allow Jump The Gun (JTG) (in scoring formula):  1

A tip: Setting JTG to 0 when having SS TP open before start gate means no time points for those starting before the start gate.

Some points around JTG and SS TP:

  1. "open" & "close" times on turnpoints are absolut. Tracklog has to cross TP cylinder inside open/close periode for given TP.
  2. SS TP open = first start gate means JTG has no effect (follows from 1. above)
    • those starting early only get distance to SS TP
    • those starting late get start gate as start time (this is the "normal" situation)
  3. SS TP open < first start gate means JTG will be in effect.
    • JTG = 0 -> those starting early get no time points but still get distance etc.
    • JTG = 1 -> those starting early get all points as normal, those starting late (after a start gate) get the start gate time.
    • JTG > 1 -> those starting early get the diff to first start gate multiplied by JTG factor.

comment:14 Changed 11 years ago by Stein Tore Erdal

Resolution: worksforme
Status: assignedclosed

or:

The taskboard:

2009-05-11

Window open:           12:00
Window close:          14:00
Start gate "periode":  13:00 - 13:30
End of task:           18:00


In FS:

TP1       open 12:00, close 18:00
TP2 SS    open 13:00, close 18:00
TP3 ....

Startgate(s): 
2009-05-11 13:30

Allow Jump The Gun (JTG) (in scoring formula):  1

The effect is anyone taking the SS tp before 13:00 will get distance to SS tp.

Those taking it btw 13:00 and 13:30 get elapsed time.

Those taking it after 13:30 get 13:30 as start-time (ie normal Race...).

Stein-Tore

comment:15 Changed 10 years ago by lopezrafa@…

Thinking ... if you can use with JG 3 decimal places, ie 0.001 is obtained by the type of test requested. pilots begin their careers before SS, for example 45 minutes, you'll have a fine of 0.45 seconds

Thinking ... if you can use with JG 3 decimal places, ie 0.001 is obtained by the type of test requested. pilots begin their careers before SS, for example 45 minutes, you'll have a fine of 0.45 seconds.

But in the example is not as close to schedule SS .. I can not close before another turpoint ..

Task:
The taskboard:

2009-05-11


Window open:           12:00
Window close:          14:00
Start gate "periode":  13:00 - 13:30
End of task:           18:00


In FS:

TP1       open 12:00, close 18:00
TP2 SS    open 13:00, close 18:00
JG=0,001
TP3 ....

comment:16 Changed 10 years ago by lopezrafa@…

if you use JG1, a pilot who began his career 13:30, have a fine of 30 minutes, you lose points for leadership.

comment:17 Changed 7 years ago by Joerg Ewald

Milestone: 1.3.0

Milestone 1.3.0 deleted

Note: See TracTickets for help on using tickets.