Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#170 closed defect (fixed)

Bug in coordinates

Reported by: Jose Luis Sogorb Owned by: Stein Tore Erdal
Priority: major Milestone: 1.2.12
Component: FsComp Version: 1.2.12
Keywords: Cc:

Description

Hello, our regional competition is located very near to Greenwich Meridian, west longitude, and we have noticed all waypoints between 0 degrees and 1 degree west (-1 in coordinates notation) are wrong. It seems as if FS doesn't add the minus sign to any coordinate beginning with -000.xxxx ,so it is a distance of more than 150 kms to the real place. Thank you, Jose Luis Sogorb

Change History (8)

comment:1 Changed 9 years ago by Jose Luis Sogorb

Ok, I have seen the problem is in GpsDump, not in FS. If you save the coordinates as Geographical file, everi coordinate between 0º and -1º (West) are wrong coded. If you save as UTM file it works fine. Jose Luis Sogorb

comment:2 Changed 8 years ago by Stein Tore Erdal

Milestone: 1.2.13
Status: newassigned
Version: 1.2.12

Indeed a bug in FsComp (nothing wrong with GpsDump as far as I can tell). Workaround (as mentioned over) is to save the file in UTM format in GpsDump. Will fix in FS 1.2.13.

Stein-Tore

comment:3 Changed 8 years ago by Stein Tore Erdal

bug in public static double ParseLon?(string lon_string) in GeoUtil?.cs.

comment:4 Changed 8 years ago by Stein Tore Erdal

Does affect any coordinates written as "W 000 ..." or "S 000 ..." in wpt files used in the FsComp task window (the format that GpsDump will create when selecting "Geo...").

comment:5 Changed 8 years ago by Stein Tore Erdal

Resolution: fixed
Status: assignedclosed

fxd in 1.2.13

comment:6 Changed 8 years ago by Stein Tore Erdal

Also fxd in update of FS 1.2.12 2009-05-08

comment:7 Changed 8 years ago by Stein Tore Erdal

Milestone: 1.2.131.2.12

comment:8 Changed 8 years ago by Stein Tore Erdal

Tested in FS 1.2.13. Works.

(Discovered other bug, task that has 10000km++ btw. turnpoints will not draw correctly ;-/)

Stein-Tore

Note: See TracTickets for help on using tickets.