Opened 3 years ago

Closed 3 years ago

#322 closed defect (fixed)

GAP2008 problem with 2014 R1.1-R1.5

Reported by: Christian Frier Owned by: Joerg Ewald
Priority: major Milestone: 2015 R1
Component: FsComp Version: 2014 R1.5
Keywords: Legacy formula GAP2008 Cc:

Description

When I try to score a task with a pilot set to 'DNF' the whole task cannot be scored. All pilots get zero points. If I set the pilots to 'ABS' the task can be scored and pilots get points. I use FsComp 2014R1.5.

The problem exists if I use FsComp 2014 R1.1 - R1.5 with GAP2008. Also if I use GAP2011 or GAP2013 the pilots will get zero points.

If I use FsComp 2013 R3.2 I am able to score the task with GAP2008 and the pilots will get points. So I guess the problem is in the legacy formula pack and not the core of FsComp.

I will attattach a zip-file with the competition files and screen shots.

Best Regards, Christian Frier

Attachments (2)

Scoring problem in FsComp 2014 R1.doc (164.0 KB) - added by Christian Frier 3 years ago.
FsComp - debugging.zip (615.1 KB) - added by Christian Frier 3 years ago.

Download all attachments as: .zip

Change History (4)

Changed 3 years ago by Christian Frier

Changed 3 years ago by Christian Frier

Attachment: FsComp - debugging.zip added

comment:1 Changed 3 years ago by Joerg Ewald

Status: newassigned

comment:2 Changed 3 years ago by Joerg Ewald

Resolution: fixed
Status: assignedclosed

Thank you for this report and the thorough debugging material. This made finding and fixing the bug very easy! :)

Problem was that when a and b are integer values, a/b is either 0 or 1, but never anything between. Needed to change them to allow for decimals.

Note: See TracTickets for help on using tickets.